2010年08月22日(日)

楽天商品検索APIで「apiVersionパラメータが正しくありません。」エラー

FavoriteLoadingあなたのお気に入りの記事に追加(cookieに保存されます)

楽天商品検索APIを使う機会がありました。
しかし以下のようなエラーが表示されます。

取得結果: ClientError
取得内容: apiVersionパラメータが正しくありません。

まずAPIのバージョンを最新にしてみます。
“version” => “2010-08-05”

これでもエラーがでる場合は・・・
APIのURLを確認します。

REST形式→ $API = “http://api.rakuten.co.jp/rws/3.0/rest”;
または
JSON形式→ $API = “http://api.rakuten.co.jp/rws/3.0/json”;
このURLを、最新のバージョンは「3.0」に変更しなければなりません。

「3.0」に変更すると、正常に取得できました。

あなたのコメントが一番最初です!

コメントをご入力ください